CEL light on, but no code.


93 GS here. 5spd conversion. This is kind of a double problem I’m having. Two questions below. Thanks in advance.

My car wouldnt start the other day. Cranking fine, but not starting (im jumping the starter solenoid to the battery to elminate any ignition problems). I dont hear the PGMFI Fuel Relay clicking like it normally does, so I took off the intake and blew starter fluid right into the throttle body. Still no starting. Even with the Main Fuel Relay out it would still start with starter fluid, correct?

Now the interesting part - I put the key in and put it in the ACC position. CEL stays on. I jump the 2P connector at the right side kick panel, take the key out, put it back in the ACC position, and the CEL stays on without any flashing any codes at me.

So my two questions are in regards to the Starter Fluid and CEL.


Find an ECU and replace the old one with the new one. Should fix it. Prolly have a bad ECU like i do.

Have you tried resetting the ECU yet? Pull the backup fuse from the under the hood fuse box. That or totally disconnect the ecu from the connectors.