The Worst thing that could happen to a swapd motor

This is a 94 Gs-R swapped G2

Last week i was driving home from work and I was messing around with my girl friend driving next to her and what not. So after messing around I try to take off . . . .here comes 6k rpm’s no vtec . . . . Im like uhm its supposed to crack at 5.2 so I think nothing of it maybe that just my wiring to my vtec solenoid is going bad since I did it myself. So I try again a few days later. Still doesnt want to go to the High speed cams. I check the oil and the oil was in between the low and the high. So It could have used some oil but it had enough to work and where vtec should have been function able.

I pull my Plugs and had oil on top of the plugs where you screw them in (NOT on the electrode side inside the cylinder head). So I vroom over to Acura pick up a whole head gasket kit and new cam seal (Hondas are known for leaking Via Exhaust cam seal(dual cam motors). I install all the head gasket, and the spark plug tube plastic pieces underneath the valve cover, and the rubber gromits that hold down the valve cover and I retorq them. Sweet! No more oil leaking! However still no Vtec. So today I decide to check oil pressure (Since vtec runs off oil pressure) I use a grease gun hose and a psi gauge and check it through the dummy plug on the front of the motor next to the vtec solenoid. Start my car and have no oil pressure. 0 psi. I rev it up to 3k still at 0, Go up to 4k 0 psi.

I am hoping for the best but Things like this only happen when you have stuff like Spun bearings and stuff. Obviously I dont have X-ray eyes and cant see but I dont hear any noises and my motor this whole time has run perfect. Starts up fine, idles fine, revs up fine. But I am stumped because If The Vtec system does work 99999999 % there is a cel code. I dont have a cel code. and i checked to make sure my cel light was working which it was. when i turn on my car it turns on and then goes off. Oh and i took off the Vtec solenoid and checked the screen and to see if it was gummed up inside and it wasnt. But I cleaned it up anyway. So its not that.

Tommorow I am going to pull my oil pan off and check the oil pickup tube. . . possibly it came loose, or the gasket went bad. ( I am thinking possibly it is sucking air and that is why the oil pressure is so low)

If This has happened to anyone, or anyone has any pointers please let me know. I have a bad feeling I am going to have to spend 2k to rebuild it . . .


what port are you checking your oil pressure from?? do you have a picture of that port? because if you had zero psi, your engine would of stalled a long time ago. i would check it from the oil pressure switch on the back of the block like your suppose to.

u can re-check your vacumn lines also, my brother routed one of my the wrong way which it was suppose to be capped… fixed it and vtec worked fine… just my 2cents…

How exactly is the right way to do that? and what wire is the oil pressure switch?

On the back of my intake Manifold I do have one vacume line that is not connected. . . . It has not been connected for a long time and everything had worked fine up untill now. I wanted to just plug it off, but when I do my iddle goes from normal to like 100 rpm.

What do you guys think the chances of my oil pump being dead are?

Not sure of your dashboard indicators - but if your oil pressure warning light is working (lights up during the bulb check and then goes out after start) you would already know if you have oil pressure. Seems to me that your engine would have seized by now if - in fact - the oil pump had failed. Vtec controls are fairly simple - 2 wires to the ECU - one for oil pressure and one to operate the vtec solenoid. Finding out whether the signal is reaching the solenoid at the proper RPM will tell you a lot - but you need a multimeter or such to start testing.

my pops has one.

What is the best place to start with it ?

in order for the ecu to send the signal to the solenoid it has to read the proper oil pressure, which you cannot build sitting in the driveway. anyone ever heard vtec crack while revving it up? doesnt happen.

so to check if the solenoid is getting the signal with a meter you would have to be on a dyno or rig up a way to drive with your test lead on the vtec wire.

da_power on your sdrev thread i explained how to jump the solenoid to take that out of the equation.

actually i just thought that if you wanted you could get a pin out of your ecm, remove the vtec wire directly from the conector and stick your test lead down in there and drive and have someone check from the passenger seat, though i doubt your ecu is the problem, unless it was an ls ecu jumped for vtec, in whicj case the internal aftermarket soldering could have went bad

Okay so here is the update. I ended up not taking my oil pan off. My pops came over to help me and we decided to check the solenoid to see if it worked. we jumped it to the battery and there you go click click sweet works good. Then we tried it with the engine running click Sweet High speed cams but i couldnt leave it on there for long because the engine was choking from the high speed cams at basically idle. but as soon as I jump it and it goes to the high speed cams, wtf The oil pressure is going crazy when its on the High speed cams. at 3k rpm’s my oil pressure was over 60psi! but as soon as you let off the jumper and let it go back to the low speed cams the oil pressure goes to zero. So I come to figure out that where i was testing for oil pressure in the head, is where you test for oil pressure when there is a problem with the Vtec mechanism. Which I did, there is no oil pressure at that outlet when vtec is not engaged. that is why the original oil sensor is in the block duh

So I was thinking about what i have done recently and i remember that I had ran a new grounding cable to my engine because the one previously was not working. So I remember that when i did all that, I disconnected my battery. !! ZOMG maybe my ECU rebooted reset with the battery disconnect for like 20 mins. So I got a laptop and connected it to my ecu. i wanted to make sure that my ecu was working. So I open on my Smanager hondata tuning program and I cant click anything. hmmmmm. So i open up a new map or whatever you wanna call it. Basically all the parameters for the ecu. I selected the whole B18C p72 ecu setup. K cool now I can select and click stuff. I disabled the Knock sensor etc. so that my CEL would go off. Sweet i got it off.

Get back in my car warm it up and try again. No vtec . . . . . what the flip. So i do the same thing again. try another setup this time usdm p28 single cam civic ecu I disable the CEL codes and nothing again . . . . .MAN what is going on… . . . . . So i try this a few more times and still nothing. I am basically stumped right now. the only other thing It would possibly be, is where the vtec wires go into the ecu clips maybe its loose, or a bad connection throughout the wire running under the hood. So tommorow I am going to jumper the solenoid wire and go to the battery for ground and from those two wires run a light into my car, and go and drive again. this way when I hit that certain rpm that vtec should kick if the light lights up than i know my ecu is working perfectly because it is sending the message to the car. and that my wiring went bad somewhere…

however if it doesnt light up, . . . Than i know my ecu is bad because it is not sending the signal . . . . And man . . .would i be mad.

Does anyone else have any ideas that I could look for also tomorrow when i start working on it again?

Vtec will not engage just by reving the motor. The car has to be moving (VSS Sensor) Has to have Oil pressure (oil pressure sensor) engine has to be warmed up (engine temp sensor) and RPM sensor (sensor in distributer). If any of these sensors are not feeding info to the ECU it will not output the signal for the Vtec selonoid to engage. Also the engine has to be grounded to the chassis. Make sure that the head and the block are both grounded to the chassis.