WTF is wrong with my integra!!!? help!

wtf is wrong with my integra…i swapped in a b16 motor a few monthes ago…and it still won’t start!..its been sitting for 4 monthes now!..i’ve got all the wires hooked up…ground wires etc…but i didn’t hook up the v-tec lines yet…but it should start.
it cranks but it won’t turn over…i’ve replaced the main fuel relay.
i towed it to a shop…and they said i’m not getting any power
at the injectors…and i have no spark…i bought the motor from
hmotorsonline…the mechanics i took it too…know nothing about
jdm swaps…so it was worthless…i have no performance import shop to help me out…so it kinda sucks !..but i can’t hear my fuel pump either when i turn the key…i’ve checked the ground wire to the thermostat housing…all hooked up…but the car won’t start!.
if i can’t start it…i’m willing to part the car out…so let me know watsup…thanks

Here you go, everything you could ever possibly want to try.…&threadid=36941

If your problem isn’t addressed here(which I guarangoddamntee it is) do a




the page is being worked on…and yea…i forgot to mention…i’ve done a bunch of searches through out the 4months its been sitting…thats why i’ve replaced the relay…pump…plugs…dis.rotor…
i don’t think its the motor…because i pulled the fuel filter plug off…and there’s no fuel getting to the motor…

Apparently my link doesn’t work, so use this one and go down until you see The_Oz’s first reply. Click that link.


thanks…i’ll see if i can find anything

if you’re not getting any spark there are a few things you can check (i’m giving this suggestion like you don’t know anything, please don’t take offense, just trying to be thorough). take 1 plug out at a time, keep spark plug wire connected and hold to a ground while someone cranks your engine. Check all four plugs. Plugs should be firing. If none fire check current at coil with VOM. Now, I don’t know if you’ve got an aftermarket ignition system, so you’ll have to know where your coil is. If its stock its an internal coil. If you’re getting nothing at the coil, check igniter connections. Pull connectors off, rub with fine grit sandpaper or scotch brite to clean terminals. Smear some dielectric grease or silicone based lube on there and reconnect making sure they’re tight.

If just one or two of the plugs wasn’t firing but others were, check resistance of wires. Should be very close to 0 Ohms. Too much resistance will cause a delayed spark.

also, make sure your plugs are good. if you’ve never checked them for functionality there’s a good chance they’re f*cked up. These JDM engines can sit around for a decade or more before they find their way in to our hands.

Another thing to check is of course your ECU. Is it throwing any codes at all? This is your best bet to finding a solution to the problem.

Again, you may have already tried these things, but I’m just giving us both a common starting ground. Even though the mechanic told you something, don’t necessarily trust it, he didn’t have any suggestions on how to fix it, so what the hell does he know? Anyway, let me know what kind of stuff you find, and I’ll keep trying to help.


p.s. do you have access to a timing light?

thanks again…no i don’t have access to a timing light…
i’m just trying to figure out how to get fuel to the fuel rail first

I had the same problem with mine…did not start for months. if you have a friend that has a running B16, swap the distributor and the ECU. I had purchased 2 distributors, but my ECU was shorting them out. I’m sure that if you get a hold of this it will run. If you do not have access to another B16, use your LS ECU and get a distributor from Autozone, just to try out use it and return it. I’m sure that the car will start.

a follow up to my last reply…NEVER trust equipment that you have not seen run before. The guy that sold me the ECU promised me that the ECU was not faulty and after 2 months of frustration, I finaly swapped the ECU…Always cover all bases, and never trust anyones word.

i tried using my LS ecu.and distributer…same thing…no start and they both worked on my ls motor

do not use your LS distributor USE a DOHC Vtec distributor…The LS did not crank for me either, but a Vtec distributor did.