b20z finally in but no spark?

ok i looked at all my electrical and checked all my grounds, fuses, spark plug wires, ect ect , and the damn thing wont start :mad: its not even getting any spark. My buddy and i chekced my starter at autozone and it worked fine, but that was 2months ago, i dont think 2 moths sittin in a box in the garage will do harm, so im at a lost ??? this project has dragged on since may. now im so close and this happens. please any info guys. much thanx :bow:

since you’re getting no spark that has nothing to do with the starter. The things you need to check are:
-spark plugs
-spark plug wires
-distributor cap
-distributor rotor
-ignition coil
-wiring in distributor
-wiring from distributor to ecu

how to check these parts can be found in the Helms manual.

After i did my swap the coil in my dist just stopped working. It worked perfectly when the motor was pulled…but put it in, and it all of a sudden was fried.

hmmm i guess i can try that. however when i mean no spark i mean when i turn the key nothin happens at all. as if my battery is dead. but the battery is brand new. everything lights up up when i put the key in, but when i turn it …nothing. not even the starter cranks at all. is this the same thing that happend to you?

then you’re using confusing terminology. no “spark” means that you are not getting any spark at the SPARK PLUGS.

your problem could be a handful of things:
-check the voltage on the battery, just because its brand new doesn’t mean it works
-check to make sure the starter wires are connected properly
-check to see that the starter is getting power and is grounded properly

since the starter isn’t making any noise it seems to me that its not wired up right. if it “whirs” but doesn’t start the car then the starter solenoid is bad. if it “clicks” but doesn’t whir or start the car then the starter motor is bad. Since its not making either noise then either both are bad or they aren’t being supplied w/ power properly.

I know you said you checked the wires, but I would re-check the wiring to the starter as well as ALL the wiring you did for the swap (especially ground wires). Not having the grounds done properly is a very common problem w/ motor swaps, its often forgotten.

Check the ignition wires too.

Originally posted by surge2k
Check the ignition wires too.

why would the ignition wires cause the starter not to function?

Stupid question and thought but, did you Have the clutch in? Sounds like maybe the clutch switch could be bad if you are getting power to everything but when you crank it it wont crank. does anything dim when you turn the key? or does it seem like you didnt even turn the key? I would look into that.

forgive the wrong terminology :bow: im just frustrated that its not workin. and i did have the clutch in however i notice when i push the clutch it doesnt go all the way to the floor, it used to prior to the swap, now it doesnt. it has an exospeed action clutch with a 95+ gsr flywheel. and i checked the starter wires and the ground and they are where they should be. my next thing is to check the battery and all the grounds. anymore info will help, ill keep everyone posted.

Look under the dash and push the clutch in with your hand and see if the switch opens up completely, if the pedal doesnt go all the way down then maybe it isnt triggering the switch the way it should.

:think: i looked and all i see the cable being pulled, the clutch is alot stiffer, other than that still nothin. if all else fails ill have the starter retested, its just a pain in the A$$ to get out.

sounds like maybe you’ve got the clutch adjusted wrong. Try loosening the clutch cable and see if you can get the pedal to go down further. Like stated before…if you don’t trip the switch with the clutch pedal then the car won’t let itself be started.

definitely try that before you retest the starter cause it sounds like a more plausible cause considering its different feeling than before. Do you have any more info that you didn’t mention in the first couple posts? The more info the better.

:clap: YES!!! it started, :bow: thanks 91IntegGS, it was the clutch cable :bang: and thank you Mk1shitrocket and surge2k for all the help:bow: ITS ALIVE!!! ALIVE!!!, does anyone have anygood follow up tips now thats its working? as you guys can see this is my 1st swap so im green. :slight_smile: thanks for all the help guys

awesome! glad to hear ya got it started! Now that its running there really isn’t anything you need to do…you’re done w/ the swap dude!

Now give us some pictures of your new beast. :slight_smile:

ok well here ya go pics of the finished project, enjoy :smile:
sorry the engine bay is kinda dirty, been sittin for a while…im just glad its done. …well almost , i have to swap over the b18a crank pulley so i can hook up my power steering, and find out why my ecu is flashin 5’s (map sensor) i hope once i do it will fix my bouncing idle. anyhow im rambling here ya go …http://www.imagestation.com/album/?id=4290569337&congratulation_page=Y

Whoa that looks great! Almost like my valve cover too, cept i have black stripes on the top. Nice work.

cool thanks man :cool: hope i didnt steal your thunder having similiar valve covers and all :bow:… let me ask ya somthin surge did yours idle funny? mine will be fine till it warms up then it will be very bouncy, it will go up to 2k rpm then drop to like 800. and it will keep doing that, my ecu is saying map sensor, which i dont know what that is. i messed with most of my vaccum lines that go the IM an TB but still cant figure it out, it does have really old gas in there from like may of 2002:shrug:

Sounds like a vacuum problem to me. I would start with the map sensor though. The map sensor is a small black box, kind of by where the steering wheel comes through. Check to see if that hose goes into the right place, and check all connections. Turn on the car and check for vacuum leaks. Report back if that didnt fix it. =)

ok guys here is an update…i checked all my hoses(again) and all are good, my map sensor is fine and still bouncy idle…i took it for a drive and it kinda lugs once in a while when i gun it. and still alot of white smoke commin out of the exhaust especially when i start it and give it some gas. so my next thing im gonna try is put in after market fuel pressure regulator and get it timed. , so here are my next questions…

  1. should i use the b20z fpr?
  2. if not what good fpr brand should i get? i have a vortech fuel rail…should i get the same?
  3. what is the white smoke?
  4. what about ecu’s? should i use another ecu?

sorry i know its alot and some are “duh” questions but just tryin to learn :bow: thanks guys

Hey Ronin,

Have you fixed it yet?

I’m having the same stupid white smoke problem. I notice when I fill the oil level back up, it smokes ALOT more. I’ve been trying to figure out this problem for weeks. At first I thought it was the PVC, but thats not it, then I’m thinking its the valve seal guides, which I will replace pretty soon. Also when I rev the engine, the smoke comes from my headers as well as the exhaust.

I have crower 403 cams and crower valvetrain on the old b18a block till I finish the b20 block again.

I thought maybe a warped head, but can’t be since the oil doesn’t have water in it, but the oil does seem a little thin. My dad said maybe gas is getting into it? I dont’ see how gas could get into the oil like that???

I would replace your hoses going to your map sensor. I had a TINY hole/rip in the hose, which made it run rich and have the bouncy idle. After replacing the white smoke depleated slightly, and the bouncy idle went away.