Blowing Alternator fuses, Cant start car at work :(

Ok, so i went to start my car today and it will just crank and not start. there is no battery light. so i check my fuses and my alt solenoid fuse is blown. So i replace it, and it blows again. i start checking all my connections and i don’t see anything wrong. is there a spot for alternator ground? i haven’t had any problems till now.
Hope someone knows something small. i even tried unplugging my turbo timer. still nothing. so i am stuck at work just waiting. and ive only got one spare fuse left that i can use lol. i really dont want to leave my car here over night, in this shady area.


The alt. is grounded through it’s chassis.

“alt solenoid fuse” ?

What is the fuse number, what is the amperage, and when does it blow, as soon as you put it in, when you turn ign. to run or when you crank to start?:tapfing: 94

it blows when i turn it to the 2nd ON poss the battery light comes on and goes off really fast and the fuse pops. the fuse number i dont know i will go look if it matters. its a 15 amp fuse for alt solenoid.

its fuse number 24 and where does it ground to the chassis, i dont see any ground going off it. only a green plug and the white hot wire.all connections are good.

also, it will crank all day but it wont start. because its like the alt. isnt working.

So my fuel pump isnt coming on either. i think there might have been a pinched wire or something. if i put a 30A fuse in it doesnt blow, but my fuel pump still doesnt come on. So i found a guy to AAA my car home for now and ill drop my tank tomorrow and look at the wires.

First, do not replace any fuse with a bigger one, you can literally burn your car to the ground.:stare:

The alt. grounds through it’s case, mounting the alt. to the motor grounds it, there is no wire.

Fuse 24 - 15A, [hot in run and start] in under dash fuse box is fuel injector relay control and fuel pump power, through fuel pump relay, it is also power for “Fuel Pressure Regulator Control Solenoid Valve”, “Exhaust Gas Recirculation Control Solenoid Valve”, [EGR] and the “Evap Purge Control Solenoid Valve” there is no alt. solenoid.

The first thing I would do is unplug the PGM-FI Main Relay, it contains the injector relay and the fuel pump relay, then, [with the proper 15A fuse in place] turn ign. to run, [2nd on position].

If fuse does not blow, you know the problem is the PGM-FI Main Relay or after it and not the control solenoids or wiring after the fuse.

It is located to the left of the steering column… let me know.

BTW you do not “drop the tank” on a G2 to check fuel pump wiring, it is all accessed from under the rear seat.:whisper:94

I have to drop the tank because i put a Walbro 255 pump in and i had to run wires to it. im gonna head out there now and start looking at the stuff.

Yea, even with it pulled it still instantly blows.

So what now? take an ohm meter and start checking all my wires after the fuse box?

Even with what pulled?

OK, so I understand, you have installed an “out of tank” fuel pump and you had to run some wiring.
What wiring and to/from where?:hmm:94

No i replaced the stock one with the aftermarket one. it goes inside the tank like the stock one. On my 90 DA you have to drop the tank to get to the fuel pump. The stock wires do not just hook up. so i had to solder the after market ones into the stock ones, and heat shrinked them.

And yes the fuse still blows with the relay unplugged.

Ok, so im retarded, we have all known this. But i pulled the wrong plug. because i just looked at the picture and ran outside. i looked at my service manual and i had pulled the Turn signal relay… So i went and pulled the real relay i was supposed to. new fuse, and went to turn it on. And no fuse blowing! so you think its my relay? or wireing problems somewhere.

Yes the problem is the relay or after the relay, to test you can use a multimeter on the 2 output lines of the PGM-FI Main Relay, yellow/black, one is the fuel pump the other is the injectors, or a simple test is the use an in-line fuse holder as a jumper, install a 5A fuse and jump from yellow/white to the to the yellow/blacks, on at a time, the one that blows the fuse is the shorted circuit, I would be willing to bet it’s the fuel pump power.:dozing: 94

Alright, i get outta work later today and i will test that. What should i be looking for on my multi meter. ohms or voltage?

And should i test with the key in the 2nd ON position?
Also is there a way to test my relay itself? i took it apart and all the solder looks good.

You will be looking for continuity to ground, there will be some, [through load] but if it shows a lot of continuity there is a short to ground.:idea: 94

Ok so i did all of this. and everything seems ok. i checked the 2 wires from my fuel pump and there is no continuity between them. i checked continuity from the ground to all the wires on my main relay plug. all pulled full continuity besides #8 GRN/BLK and #3 YEL/BLK they polled about 75% continuity. Al voltage polled correct also, i think.

Ive tried all the tests on here. It seems my problem wire is that #3 i cant tell what that goes to.

One of the yellow/blacks is power out from relay to injectors the other yellow/black is power out to the fuel pump.

Have you tried the “jump” from the yellow/white, [1] to the yellow/black, [3 and 7] one at a time, using a fused jumper line, or you can jump from black/yellow, [5] to the yellow/blacks, just turn on the ign., use a 10A fuse.

I do not know which black/yellow is the fuel pump power and which is the injector power, but if the problem is #3 when you jump power to it the fuse will blow, if it is the fuel pump you will not hear the fuel pump :idea:94

ok, so i did the jumper with inline fuse. And when ign is off and i jump YEL/WHT to #3 YEL/BLK its all good and then to #7 YEL/BLK the inline fuse gets Destroyed, not just pops, but it like completly explodes lol. Same with ign on and BLK/YEL to #7 YEL/BLK

Whats up wit dat?:squint:

You have a dead short on the #7 black/yellow.

When you jumped to the #3 black/yellow, [fuse did not blow] could you hear the fuel pump running?:think:94

Nope. i did not hear the pump run.