CEL Code 12 EGR Valve

1991 Acura Integra LS (B18A1)
Automatic Transmission
160k miles

Hi everyone! First time poster in this forum, I hope I am doing it right and apologies to the admins if not.

I am continuing my thread from Team Integra where I previously seemed to have fixed this issue with code 12, but when driving home last night, my check engine light came on and I am getting the same code. This morning, I tried to fix the issue the same way as I did previously by cleaning the EGR valve with brake clean and performing an ECU reset, but the check engine light came on right when I started driving. I want to give the ECU reset another try tomorrow when the engine is cold again so it can properly recalibrate.

I’ve read some threads here about checking vacuum lines and such or replacing the EGR valve system entirely. Also considered doing an EGR delete as I read it is mostly for emissions purposes and the car can run without it fine. Curious if anyone has found a lasting solution for code 12 so the check engine light doesn’t come on. Car was doing great for almost three weeks til yesterday! Thanks in advance for any help.

1 Like

I’m still working on going through the harness combos here: EGR valve options - ASSISTANCE / Stock Engine-Bay Components - G2IC - Generation 2 Integra Club

So far resetting the ECU (or a NEW ECU) has not worked. I’m hoping I will find a wire combination that will work.

wish I could help, my db1 luckily hasn’t had any EGR issues or codes yet…

Welp resetting the ECU this time around after cleaning the EGR valve did not work. CEL is back with the same notorious code 12 and comes on when accelerating. I still have to commute a little for work so planning on driving with the CEL until I can get it fixed. Other threads seem to suggest this isn’t too big of an issue apart from some fuel economy during city driving. Curious if anyone has suggestions or tips for things to avoid when driving with CEL. I am going to keep an eye out on local junkyards and try replacing the entire EGR system.


Writing an update to describe the symptoms I am experiencing with this issue after driving around with the CEL on for a few days now.

First thing is that the CEL does not come on immediately but only once the car begins moving and is at operating temperature. Based on other threads, this makes sense as the computer checks for the signal only when the car is moving and driving at a certain RPM range.

The idle is the most noticeable symptom. Generally, the RPMs tend to be higher than normal when at a stop. Additionally, the RPMs seem to fall slowly from 2k down to 1k. When slowing down and RPMs reach 1k, there is a slight jump in RPMs before going back down again to 1k or a bit below it.

Last thing is that it almost sounds like I can hear air rushing in or going through the system in a way I did not notice before, particularly when slowing down to a stop. It’s like a very gentle whooshing sound like a literal home vacuum shutting off. I am thinking I have an air leak somewhere or that the EGR valve is actually getting stuck open and so air continues to be pushed into the intake. If I am conceptualizing this all correctly, then this would explain the high RPM and the slow fall of RPMs when coming to a stop since the added exhaust gas acts like a turbo and adds extra polluted air when it’s not necessary. I am curious if the symptoms I am describing may also have something to do with the idle air control valve (IACV), which other threads have said may deserve a cleaning too. However, with the CEL continuing to throw the same code, I think my plan is to do a more thorough inspection of the vacuum lines, replace the gasket for the EGR system, and relube the position sensor. I also want to check the connection points for the EGR hookup, but I have been having trouble carefully disconnecting it. Any tips or thoughts are much appreciated!

Yup that’s the correct harness. I have that spliced right now with the new EGR I got that I’m trying to make work. I don’t have any of the other symptoms regarding idle that you mention, but it definitely comes on once the engine is warmed up.

I fixed it again! Here’s what I did this time:

Given the symptoms I was experiencing while driving, my assumption going into fixing this the second time around was that the EGR actually was not operating correctly and this isn’t a case of a bad ECU or wiring connections. I read up on a bunch of forum posts and watched videos about different EGR types and learned that mine is a vacuum operated EGR valve:

So for the valve to operate correctly, a vacuum needs to exist in the upper part to pull the valve open against the spring. So here’s my EGR below, complete with the valve position sensor on top of it which the ECU uses to check for the appropriate voltage (higher voltage means valve is more open) at different driving conditions (ex: idle versus driving at 2k rpms). I noticed before that the topper wasn’t exactly on there particularly tight, I could nudge it around with little effort and so I thought maybe air was escaping there and not allowing for a proper vacuum to exist, resulting in the valve not opening as much (if at all) as it was supposed to, resulting in decrease performance and for the ECU to throw a code basically saying “low voltage, EGR isn’t working properly.” I grabbed a straw and just tried blowing into the vacuum inlet (the little L shaped thing sticking out of the middle section below the black sensor). Sure enough, I could hear air and feel it coming out from in between the sensor and the diaphragm housing below it. In the last image, I tried to capture the loose fitting of the topper, which had a big enough gap that I could see light on the other side. When I pressed down on the sensor to tighten the seal more, I no longer could blow into the inlet, suggesting that it was air tight in there and would hold vacuum. Seemed like I found my problem!

One user on a Prelude forum said that he fixed this by replacing the triangle gasket on the sensor with an o-ring that he managed to squeeze into it to create a better seal to hold the vacuum. My plan was to try the same, but my AutoZone didn’t have o-ring sets so I instead went with a different solution of just figuring out how to fix the sensor more firmly on top of the diaphragm housing. You can see that by default, just those two clips on either side of the sensor topper push down on the sensor. My thinking was that if I could tighten that seal by adding force downward on top of the sensor, the same way I did with my hand when blowing into the inlet, then the vacuum would function as it should without any leaks.

You’ll see that the two silver clips that hold the sensor down are attached to a single metal plate, which goes on top of a rubber cover which encases the plastic sensor housing. In between the rubber cover and the metal topper, I added a very small flat piece of metal to add a bit of height, creating more downforce and tightening up the seal between the sensor and the diaphragm housing when the clips are locked into place. Please be kind about my creative vacuum tester in the middle image, which shows that the diaphragm is now air tight as the plastic squeeze bottle doesn’t fill up with air. The far right image shows that the gaps that were there before are no longer there so air should not be able to escape from there anymore.

I put everything back together, reset the ECU with the same procedure as before (disconnect battery + pull ECU fuse, wait for a few minutes, reconnect, wait for a few minutes, start and idle for 15 min til at operating temp, stop engine), and then took it for a drive and did not get a CEL! Moreover, the car was driving with good power, shifted through all the gears, and I was not hearing any air whoosing when coming to a stop. Crossing my fingers that this fix will last!

1 Like

Wow glad you figured it out! My situation may be different though because it holds vacuum. I even got a vacuum tester. Argh!